BestParking.com Outage
Incident Report for Arrive
Resolved
This incident has been resolved.
Posted Aug 09, 2018 - 20:00 CDT
Monitoring
BestParking.com is back up, we are continuing to monitor
Posted Aug 09, 2018 - 17:49 CDT
Investigating
We are currently experiencing downtime on BP. ParkWhiz.com continues to function properly.
Posted Aug 09, 2018 - 17:16 CDT
This incident affected: ParkWhiz Website.