Payment processing degraded performance

Incident Report for Arrive

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 14:32 CDT

Monitoring

Payment processing response times have returned to normal, we are monitoring for further issues
Posted Apr 21, 2025 - 13:06 CDT

Investigating

One of our payment processors has indicated degraded performance impacting our systems
see https://status.adyen.com
Posted Apr 21, 2025 - 12:30 CDT
This incident affected: Arrive API v4, ParkWhiz Website, and ParkWhiz App.